VMware Virtual Data Protection (VDP) SSL Fix

Introduction

If you use VMware VDP 5.1 or newer for your backup solution. Then you may have seen that you can’t access the /vdp-configure or /FLR recovery pages. That is because most current browsers have been updated to no longer accept old certificates that VDP uses. you need to apply the VMWare VDP SSL Fix.

Root Case

The root cause of the issue with VMware Virtual Data Protection (VDP) 5.1 involved outdated certificates. The certificates used by VDP 5.1 were not compliant with newer web browser security standards, leading to compatibility issues. As a result, users were unable to access certain web portals using modern browsers. This was primarily due to the browsers enforcing stricter security protocols, which the older certificates in VDP 5.1 did not meet. This mismatch in security standards created accessibility problems for the users.

Solution

The VMWare VDP SSL fix for it is simple though, head to VMware Kb article 2111900 for the script to fix it and the installation instructions. The fix itself only takes about 10 minutes to apply and you’ll be back up and running in no time! Overall the process involved regenerating certificates and assigning them to the correct services. Then restarting the services so all the subcomponents can properly work together.

For Reference here is the VMware KB Article 2111900 artical.

This is one of the many reasons why I love Veeam.